中国信息官CIO精英 前沿视野 经验之谈 职业发展 信息官杂谈 | 产品资讯笔记本 商用电脑 服务器 办公 网络设备 存储设备 软件 显示设备 其他

您当前的位置: 首页 > 资料库 > 实用技巧 〉技巧:为交换机配置VLAN网络

技巧:为交换机配置VLAN网络

2008-05-09 16:06:26

    本篇文章我们要介绍如何通过图形化界面对交换机进行VLAN配置,拥有图形化的配置界面,是很多厂商在介绍产品时会着重强调的一个优点。

    但在实际工作中我们发现,如果一名网络工程师没有通过CLI(命令行界面)模式成功的配置过VLAN的话,即使使用图形化界面,也无法顺利的完成VLAN的配置,在网络工程师的生涯中,没有什么捷径可走。下面我们会分两部分,从使用命令行的配置VLAN入手,将相关的概念逐一介绍清楚。

    通过命令行方式在交换机上配置VLAN

    为了让这个例子更有权威性,我们摘取了CISCO网站上的一篇介绍VLAN配置文章(小提示:CISCO公司的网站技术资料极为丰富,可以系统而全面的学习到交换机配置的各个方面的知识,而且是免费的,大家在遇到交换机配置方面的问题的时侯,不妨多访问一下CISCO的网站,一定会有收获的),本例中所用到的例子网址如下:http://www.cisco.com/en/US/tech/tk389/tk815/technologies_configuration_example09186a008015f17a.shtml。
  
    这是一个典型的上网用的配置。

    (一)CISCO3550交换机的配置

    CISCO3550交换机上联一台路由器(拥有互联网出口),下面连接一台CISCO29450交换机,在CISCO3550上还对各个VLAN作了定义,CISCO3550交换机的配置如下所示:

    Catalyst 3550 (Catalyst 3550-48 Switch)

  Cat3550#show running-config
  Building configuration...
  Current configuration : 3092 bytes
  !
  version 12.1
  no service single-slot-reload-enable
  no service pad
  service timestamps debug uptime
  service timestamps log uptime
  no service password-encryption
  !
  hostname Cat3550

  ip subnet-zero

    !--- Enable IP routing for interVLAN routing.(这一步非常重要,通过ip routing命令了实现了各个VLAN间的路由,这样各个VLAN间是可以互访的,但是由于每个VLAN都是一个独立的广播域,所以即使在一个VLAN中发生诸如ARP地址欺骗之类的病毒,也不会影响其它的VLAN)

  ip routing
  !
  spanning-tree extend system-id
  !
  interface FastEthernet0/1
  no ip address
  !
  !--- Output suppressed.
  !
  interface FastEthernet0/5
  description to SERVER_1

  !--- Configure the server port to be in the server VLAN, VLAN 3.

  switchport access vlan 3

  !--- Configure the port to be an access port to prevent trunk negotiation delays.

  switchport mode access
  no ip address

  !--- Configure PortFast for initial Spanning Tree Protocol (STP) delay. Refer to
  !--- Using PortFast and Other Commands to Fix Workstation Startup Connectivity Delays
  !--- for more information.

    (这里又介绍了一个非常重要的概念,即如果确认交换机下某个端口连接的是一台重要的服务器,那就可以将该端口设置为“spanning-tree portfast”状态,从而实现服务器与交换机端口的快速连接)

  spanning-tree portfast
  !

  !--- Output suppressed.
  !
  interface FastEthernet0/48
  description To Internet_Router

  !--- The port that connects to the router converts into a routed (L3) port.(fa0/48是上连到一台路由器)

  no switchport

  !--- Configure the IP address on this port. (为了实现与路由器的通讯,在端口上设置了IP地址)

  ip address 200.1.1.1 255.255.255.252
  !
  interface GigabitEthernet0/1
  description To 2950

  !--- Configure IEEE 802.1 (dot1q) trunking, with negotiation, on the L2 switch.
  !--- If there is not support for Dynamic Trunking Protocol (DTP) on the far switch,
  !--- issue the switchport mode trunk command to force the switch port to trunk mode.
  !--- Note: The default trunking mode is dynamic auto. If you establish a trunk link
  !--- with the default trunking mode, the trunk does not appear
  !--- in the configuration, even though a trunk has been established on
  !--- the interface. Use the show interfaces trunk command to verify the
  !--- establishment of the trunk.
  
 

投稿邮箱:cio114@foxmail.com